Ramdisk format errors

Re: Ramdisk format errors

par Andrej Gorjan,
Nombre de réponses : 0

Thank you for the advice, I appreciate it. I tried adding the commands to the script but got errors that they were not implemented. Looking at this document
https://www.digi.com/resources/documentation/digidocs/PDFs/90000852.pdf (page 9)
u-boot doesn't support the commands 'set' and 'trap'. I assumed that you were referring to the 'u-boot.script' file and not the 'config_system.sh' file, maybe this was my mistake.

I tried compiling zImage from the commit in the document and I added the 'extern' keyword to the two lines, but I got the same result as last time. You mentioned that the problem might be caused by errors when compiling zImage, and I do get these two

<stdin>:1310:2: warning: #warning syscall preadv2 not implemented [-Wcpp]
<stdin>:1313:2: warning: #warning syscall pwritev2 not implemented [-Wcpp]

But since they are warnings, I did not give them much thought and there were no other errors reported. But I do not see how this could cause a corrupted ramdisk.

Best regards,
Andrej Gorjan