Cannot connect to the board

Cannot connect to the board

by Orégane François David Desrentes -
Number of replies: 1


I am on ubuntu and I'm having trouble connecting to the board. I cannot seem to detect the USB link to the board.

./nios2eds/ jtagconfig
No JTAG hardware available

I have changed the file 51-usbblaster.rules like explained here (and it was also done for last semester) but it still doesn't connect.

I have tried going with the provided virtual machine but the board does not show in the connected USB devices for the VM.

Any idea on what could be happening ?

In reply to Orégane François David Desrentes

Re: Cannot connect to the board

by Alexandre Chau -

Hi Orégane,

Apologies for the delay in answering.

I understand you installed Quartus directly on your machine, which specific version did you use? There are known issues if it's not 18.1.

As for the VM, I may know what's causing your USB devices to not be recognized: if your host is Linux-based, you need to add your username to the vboxusers group (on the physical host machine) to be able to catch USB peripherals inside the VM. The command is "sudo adduser $USER vboxusers" then you need to reboot. See

Let us know if you still have issues afterwards,


The TAs team